4D externel Mac 64bit Problem

Hallo Leute,

ich habe ein 4D Plugin (32 bit) unter Xcode 8 für den Mac geschrieben und möchte jetzt auch eine 64bit für den Mac haben.

Kann mir jemand sagen, was ich in Xcode ändern muss?

in den Build Settings - Architectures auf “universal 32/64 bit” umgestellt. Der Code hat sich verdoppelt. Unter V16 32bit geht es und unter 64bit stürzt 4D ab. Von 4D benutze ich die V16.1.

Was mache ich falsch?

VG

Uwe

Vergewissern Sie sich, dass Sie auch das aktuelle/letzte Plugin SDK haben:

http://sources.4d.com/trac/4d_4dpluginapi

Das Projekt basiert im Grunde auf der V15, weil ich es zu dem damaligen Zeitpunkt (vor einem Jahr) so angelegt habe und natürlich die neueste Version genommen habe.

Einfach debuggen. Das Mac-Crashlog sagt ja genau wo es kracht!

Danke. Ich habe jetzt ein verstecktes 4D external V16 gefunden. Da ist jetzt auch das Carbon-Framework ersetzt durch verschiedene Cocoa-Frameworks. So ist es richtiger.

Ich werde mein Code in diese Version reinkopieren und testen

Problem ist erstmal gelöst. Ich kann jetzt testen. Der beste Weg war ein die neuen Plugin-Dateien in mein altes v15-Projekt zu kopieren.