4D-jpブログ:太くなったボーダーハイライト

ブログでhttps://4d-jp.github.io/2019/04/18/thick-border-highlight/太くなったボーダーハイライト>
とあるのですが、10.11ではならないのは仕様でしょうか?
どこかに設定があるのでしょうか。 :frowning:

17R4のシステム要件は,

10.12.6-10.14

となっています。

https://download.4d.com/Documents/Products_Documentation/LastVersions/Line_17R4/VIntl/4D_v17_R4_SystemRequirements_EN.pdf

10.11で17R4を起動された,ということでしょうか。

「設定のようなもの」があるわけではないと思いますが,
ランタイムやSDKのバージョンによって,表現が違うのかもしれません。

: Keisuke MIYAKO

17R4のシステム要件は,

10.12.6-10.14

となっています。
え!?:oops:
対応バージョンじゃなかったんだと再度確認してみました。
するとv16、v17の最新バージョンも10.11は除外されていました。
マイナーバージョンで対応はずれるのっと有り?ですか。 :frowning:

仕方だないので10.12.6へアップグレードしてみまいた。
[]30126906;“Your comment here…”[/]

私の環境ではならないみたいです。なぜでしょうか?

: Keiji HOSAKA

マイナーバージョンで対応はずれるのって・・・

対応表を要約すると,下記のようになっています。

https://download.4d.com/Documents/Products_Documentation/LastVersions/Line_17/VIntl/PDF_Format/4D_v17_0_SystemRequirements_EN.pdf17.0>: 10.11-10.13
https://download.4d.com/Documents/Products_Documentation/LastVersions/Line_17/VIntl/PDF_Format/4D_v17_1_SystemRequirements_EN.pdf17.1>: 10.12-10.14
https://download.4d.com/Documents/Products_Documentation/LastVersions/Line_17/VIntl/PDF_Format/4D_v17_2_SystemRequirements_EN.pdf17.2>: 10.12-10.14

https://download.4d.com/Documents/Products_Documentation/LastVersions/Line_16/VIntl/4D_v16_0_CertificationMatrix_EN.pdf16.0>: 10.10-10.12
https://download.4d.com/Documents/Products_Documentation/LastVersions/Line_16/VIntl/4D_v16_1_Certif_INTL.pdf16.1>: 10.10-10.12
https://download.4d.com/Documents/Products_Documentation/LastVersions/Line_16/VIntl/4D_v16_2_Certif_EN.pdf16.2>: 10.10-10.12
https://download.4d.com/Documents/Products_Documentation/LastVersions/Line_16/VIntl/4D_v16_3_Certif_EN.pdf16.3>: 10.11-10.13
https://download.4d.com/Documents/Products_Documentation/LastVersions/Line_16/VIntl/4D_v16_4_Certif_EN.pdf16.4>: 10.11-10.13
https://download.4d.com/Documents/Products_Documentation/LastVersions/Line_16/VIntl/4D_v16_5_Certif_EN.pdf16.5>: 10.12-10.14

お気づきのように,3世代前までがサポート対象となっているわけですが,16.5(10.11が外れたバージョン)の脚注には,

: 4D

Apple stopped to provide security updates to OS X El Capitan (10.11)
since Summer 2018. Therefore, unfixed security issues, using of this
system for professional purpose cannot be supported anymore, please
update to a newer OS.

とあって,AppleがサポートしていないOSなので,4Dとしてもサポートできない,という趣旨のことが書かれています。

サポートしなくなったならアナウンスしてほしいです。
新しいOSへの対応についてはアナウンスがあったので…

とりあえず、新しいOSに対応されればサポートされるOSは2世代前までと考えておきます。 :pray:

本題からずれとる :mrgreen:

開発部から回答がありました。

太くなるのは

システムが「10.14以降のとき」だそうです。

: Keisuke MIYAKO

開発部から回答がありました。

太くなるのは

システムが「10.14以降のとき」だそうです。

そういう事ですか。了解しました。 :mrgreen: