4D Pop and 4DPop XLIFF components for 4Dv17

Hello All,

We are moving our application from v15 to the latest 4D v17 and we are looking the process to move resources from STR# to XLIFF.

I’ve been searching so far for 4D Pop and 4DPop XLIFF components and their documentation of how to create XLIFF files but with no success so far.
Looking at the knowledge base from 4D, the tech notes:

….
To download a set of tools to help with the conversion process refer to:
4D Pop Collection

For the latest information on the 4D XLIFF support please see the documentation page:


….
Both links above redirects me to a generic page in 4D https://us.4d.com

I’ve searched http://forums.4d.fr, but could not find anything here.

Anyone that can help me where to find 4D Pop and 4DPop XLIFF documentation and components for v17?
I only Found 4D pop from :
https://download.4d.com/Components/4Dv16/
https://download.4d.com/Components/4Dv17/

In 4D v15 R5 I did find both components and the sources.
I ran rom my Application using 4D v154D, Pop_Palette and then selected xliff component. But i get error
in EDITOR_LOAD_FILE (4DPop XLIFF) @line 51 (Pointer is not properly initialized)


Also tried to recompile and build both components in v17.
I run my application in v17 but again when i accessed xliff component i get error in EDITOR_LOAD_FILE (4DPop XLIFF) @line 61 (Pointer is not properly initialized)

What seems to be the problem?

Many thanks,
Yannis

Download the good version of 4D Pop see this https://forums.4d.com/Post/FR/27947522/0/0/#28239296thread> :wink:

Hello and thanks for the reply.

I have already read this thread and downloaded the 4D pop from v17 and v16 (i mentioned it in my initial post)
There was no 4D pop XLIFF inside. So how is going to work??

I made another try to use 4D pop from v17 together with
4Dpop XLIFF i found from 4D v15 R5 and compiled it in v17 but i get error in EDITOR_LOAD_FILE (4DPop XLIFF) @line 51 (Pointer is not properly initialized)

BR
–yannis

Ok, sorry I didn’t know that 4D Pop Xliff wasn’t there :-?
Is 4D Pop Xliff only for 4D Partners :?:

if you are Partner you can download the source of all 4D Pop http://forums.4d.com/Post/FR/28184952/1/28184953#28184953here>

Hello,

Thanks for the link.
I am a 4D partner and I’ve beed trying to connect to beta.download.4d.com but with no success.

Hi Leslie,
if you copy/paste the link under “source code download”, you’ll obtain a ftp link of this kind:
ftp://login:password@ftpServerAddress/Sources/
Then it depends on what ftp client you use : some allow to use the whole url, some will need to extract each part (login, password, ftpServerAddress) in different fields.

Simply try to use FireFox to connect… :wink:

Ok i will try.

I was using Transmit.

Thanks

With Transmit it’s a bit complicated

  • you have to copy the link
  • allow to open Transmit (in Safari)
  • cancel the login (in Transmit)
  • paste the link in Transmit window
    Done

Transmit don’t receive correctly the link with login and password from Safari :cry:

I use these ftp clients:

  • cyberduck, drag’n drop the link on its icon works
  • filezilla, paste the whole link in the “host” field, the button “fast connect” will parse it correctly.