App SDI avec barre d'outils

Product :4D - 4D Server
4D : v16 R4
OS : Windows 10

Hello,

Par curiosité : quelqu’un a-t-il déjà essayé de passer en SDI un app avec une barre d’outils ?

Chez moi, ça ne se passe pas bien du tout :
– la barre d’outils est bien affichée (sans menu),
– la constante “en haut”, pour positionner les fenêtres de formulaires n’est pas gérée,
– même en décalant (d’un certain nbre de pixels), ça se passe mal, les fenêtres peuvent passer sous la barre d’outils, et j’ai ensuite très vite des problèmes avec les menus qui ne s’affichent plus correctement, etc.

Comme mon planning pour les jours qui viennent est chargé, je laisse tomber provisoirement, mais je suis déçu. J’espérais en avoir fini avec la fenêtre MDI pour cette appli, dans sa version Windows, et ça ne sera pas pour tout de suite…

Pour info : ma barre d’outils est gérée dans un worker, par

<code 4D>
<>WRef_Bar:=Créer fenêtre formulaire(“Barre”;Form fenêtre barre outils)
DIALOGUE(“Barre”;*)

</code 4D>

(et tout se passe bien, sur Mac ou en MDI sous Windows)

Note : J’avais complètement raté l’existence d’un hotfix pour la R4. Ça n’a peut-être rien à voir, mais je le signale quand même. Je vais charger cette version et tester à nouveau (quand le serveur de chargement de 4D sera en meilleure forme…)

Bonjour

J’ai le même souci avec la V16R6

Les menus n’apparaissent pas, sauf à faire surgir une autre fenetre, et la commande “fixer barre menus” ne fait rien.

Je testerais en V17, mais j’ai peur que ça soit pareil.