Cannot load internal component development.4DC

4Dv17R4 build 233874
Windows Server 2019 1809 build 17763.397 (64bit)

An installed 4Dv17R4 application began not correctly launching this morning on the error(s).

650 (xbox) Folder (name) not found (path) xtoolbox task 1444
Cannot open the structure of the database development
Can’t load component development.4DC component ‘4DRT’ task 1444

This error occurs for every c:\Program Files\4D\Resources\Internal Components\ of which there are six internal components.

I re-installed the 4Dv17R4 application and the newly installed app has the same error.

I’m suspicious of the OS.

4D Server is running on this same machine and it uses four of the same internal components. I’m concerned that if I restart 4D Server it will fail also.

Please help!

David Ringsmuth

Windows Server 2019 may require a compatibility mode enabled to allow 4D to run.

When it was enables, the 4D sofware began running correctly.

by “compatibility mode” do you mean FOD?

https://docs.microsoft.com/en-us/windows-server/get-started-19/install-fod-19

It looks like FOD is added to Server Core to increase application compatibility without enabling the full desktop experience.
{
App Compatibility, a Feature on Demand for Server Core, significantly improves the app compatibility of the Windows Server Core installation option by including a subset of binaries and packages from Windows Server with Desktop Experience, without adding the Windows Server Desktop Experience graphical environment
}

As a reminder, previous versions of the 4D Certification Matrix used to include the following text:
• 4D Windows versions are not compatible with the ‘Server Core’ option of Windows Server

To summarize:

  • To use 4D v17R5 on Windows Server 2019 Server Core it is necessary to switch the mentioned FOD on.
  • To use 4D v17R5 on Windows Server 2019 (graphical edition, how it is called correctly?) it is not necessary to switch this setting on.

Am I right?
The https://download.4d.com/Documents/Products_Documentation/LastVersions/Line_17R5/VIntl/4D_v17_R5_SystemRequirements_EN.pdfsoftware requirements document> by 4D doesn’t mentioned anything regarding Windows Server settings.

And how is it with older 4D versions like 4D v17.2?

Regards
Lutz

4D - any version released as of today - is not certified to be used with Windows Server “Server Core”.

Not with Windows Server 2016 or not with Windows Server 2019.
Not with v17 or v17.2 or R5 or R6.

OK, thanks Thomas.
But regarding the mentioned FOD setting in Windows Server 2019: Is it necessary to set it using the normal Windows Server edition (not “Server Core”)?

We are just planning to migrate to 4D v17R5 and want to use it on Windows Server 2016 or 2019.

Regards
Lutz Epperlein

I am not aware of any “special setting” for Windows Server 2016 or 2019.

Server Core runs without graphical user interface. You cannot use installers or Event Viewer or Task Manager, everything needs to be done via Powershell.
4D is not certified for that mode.

4D is designed to have a graphical device. It is using such for many purposes, by example for printing, which is possible on the server. 4D Server can run 4D Write or other plugins, using a graphical context (some people use such plugins to create pictures). 4D Server supports 4D Write Pro which requires a graphical context, to calculate font sizes, etc.

While it would be possible to create a reduced edition of 4D Server, working only as a database server with drastically reduced command set (which blocks commands needing graphical user interface, printing, all kind of graphic calculations, etc), so far this is not planned. If you do have requests for that: please use feature request forum.

While Server Core + FOD (https://docs.microsoft.com/de-de/windows-server/get-started-19/install-fod-19) increases compatibility and it might work or seem to work, there is a high risk that some use cases (commands, plugins, situations) might fail, producing wrong results or crashes.

To be clear, we never wanted to run 4D in a “Server Core” environment.
But I’m a bit puzzled since David Ringsmuth seemed to have problems to run 4D on a Windows Server 2019. He was able to fix it if he switch this FOD setting on. So I assumed he tried to run it on a Server Core system.

So my question again, do we have to activate this obscure setting of Windows Server 2019 (normal edition) if we want to run 4D v17R5 or 4D v17.2 (as a Windows service) on it?

Regards
Lutz Epperlein

No.
We run our certification with “standard” Windows Server installations. We just use Microsoft installers. We do not change them by adding or removing services, options, preferences.

The link I’ve posted to Microsoft says that FOD is only required to Server core.
As result, my post was only related to Server core.

Thanks. And it is the information I want to hear :slight_smile:
So it would be interesting on which system David tried to run 4D. Maybe he can chime in again.

Regards
Lutz Epperlein

I emailed him yesterday - this was a cloud service deployment… the people in charge of the cloud made the change for him (he wasn’t aware of what was changed).

Seems like a highly-specific issue to whatever cloud provider he was using.

Please forgive my late reply.

My day began in an extremely rare about of pain and I’m just getting to my desk. Won’t be taking any more cascara sagrada. 8-()

Jeffrey answered the question as well as I could. The cloud support person said they, “fixed the issue with compatibility mode”.

I looked information on 4Dv17R4 matrix, or similar, but had not found it.

I’m glad that I could be some help to others!

Thanks Jeffrey!

:slight_smile:

Miyako,

FYI: The WS2019 OS continues to cause problems for 4D Server’s backup script that for me includes an automatic restore, and a 7zip ultra compress/encrypt.

The Anti-Virus OS component, the Firewall…, my application is not yet running as it should.

4D / 4D Server do launch correctly in “compatibility mode”.

Hi David,

As Thomas Maul previously described, 4D has never supported ‘Server Core’.

So please make sure that the Standard/Full edition of WS2019 is installed instead of WS2019 Server Core.

-Tim

Tim,

Thank you!!

Exactly what I needed to tell the cloud tech support people.

Please warn others…

:slight_smile: