Can't connect to built server - help!

4D v17.1, Server 64 bit, Remote 32 bit.
Built server with OEM keys.

Installing on AWS Windows Server 2019 Datacenter.
Server is running as a service.
Login has been tried as local system account, and as an administrative user account.
(Also doesn’t work if server is run via double-click RunAs Administrator)

Running remote app on same machine, same administrative user account mentioned above.

We have allowed both apps through the local Windows Defender firewall.
The firewall is OFF for the Private network.

4D Web Server is running successfully - can connect via AWS Proxy from outside.
This same setup was running before on this AWS server. At some point the user profile became corrupt, so we just created a new one. I think this problem showed up first when the old profile was corrupted.

The IT person setting this up is smart, but not always communicative.
Error messages are attached.

[]31155796;“This error comes up instantly”[/]

We have a Win4DX folder in the Server Database folder
It contains Basic4D!?!! (32 bit only - we are working on getting rid of it).
However, we removed the folder, restarted the service, and the errors still come up.
Is it finding a Win4DX folder inside a Plugin?

[]31155807;“Win4DX!”[/]

Plugins list:
[]31155846;“Plugins”[/]

Thanks for any help,

Jim Hays

Jim, if the web server is running then it could be a port blocking Problem.

Try to add the tcp ports 19812-19814 to the firewall settings to all 3 environments.

In and Out

FYI you need TobitProXl 531 not 530 to avoid the windows defender problem and delete the 4D folders cache with the Cache.xml inside on the server

Armin

Hi Armin,

That screen shot showed a local dev folder list of plugins. Our production systems use v531 - thanks!

I enabled the firewall rules for domain - private was already enabled.
netstat -a -n shows the server listening on ports:

TCP 0.0.0.0:19812
TCP 0.0.0.0:19813
TCP 0.0.0.0:19814

Still no luck.

I have a workaround - uncheck the Encrypt Client-Server Communication box.
The default cert.pem and key.pem files are present in the server and client resource folders.
(We’re using the new network layer)

I know 4D recommends that we replace these files.
Could we use the same cert we use to sign our installers? (is that safe?)
Or should it be a cert owned by the customer?

BTW - I did a new build using v17.2hf1 since I saw that v17.2 was the first version to be listed under system requirements to allow Windows Server 2019. That version update had no effect though.