Cant open 4D design on developer, only on server?

Server: osx 10.13.6, 4d server v16.6 32-bit, uncompiled
Developer: osx 10.14.6, 4d.app v16.6

Copies the app from the server to developer. Cant go to design layer on developer, the 4d developer crash. Have a trace in on startup, can go step by step but crash instantly trying to click on “Abort and edit” button in the debuger.

No problems with the same application running on 4d server, log in with client, goes to 4d design layer, no problems. The app is in use with 15 clients, web etc every day.

Used Maintenance, repair, compact structure several times, even upgrad to v17 but same behavior and result - crash when goes to design layer.

  • any quick fix or ideas?

Helge Antonsen

There might be something trying to execute in the Debugger’s Expression Pane. Try holding down the shift-key before getting clicking on the Trace button. This will clear everything from the Expression Pane.

Thanks but it did not help. Crash at once when hitting the abort and edit button, with or without shift-key.

If i run the startup, i get the start menu and the start form with buttons to show different parts of the application. This are loaded in new processes - they start but crash before the window with lists shows up?

Hilsen

One of the developer windows, possibly Explorer, might be trying to render a preview, possibly a form, that is raising a low-level exception. Can you record the screen and play in slow motion to identify the exact moment the crash? Also, there must be a system crash report that details the stack frames that lead to the crash.

Here is the log. Hope it tells you more then i get out of it :slight_smile:

Thread 22 Crashed:: Design process (id = -5)
0 com.4d.4d 0x00453042 VMethodInfo::VMethodInfo(VMethodList const*, procrec const&) + 18
1 com.4d.4d 0x00454335 VMethodList::RetainMethodInfo(long) const + 77
2 com.4d.4d 0x0037e383 V4DDatabase::RetainMethodInfo(long) + 31
3 com.4d.4d 0x0045f55a VObjectsLists::_UpdateMethodsListItem(VTreeItem*, long) + 42
4 com.4d.4d 0x0045d81a VObjectsLists::_UpdateMethodInMethodsList(long) + 966
5 com.4d.4d 0x00458c20 VObjectsLists::GetMethodsTree() + 26
6 com.4d.4d 0x003c08b0 RemplisProcsExplorer() + 300
7 com.4d.4d 0x003c2d63 VExplorer::_InitLists() + 65
8 com.4d.4d 0x003c2e72 VExplorer::Show(ExplorerListKind, void*, long, long) + 34
9 com.4d.4d 0x0031972f structure2(V4DTaskConcrete*, xbox::IRefCountable*) + 581
10 com.4d.4d 0x0038ed24 Task4DProc(V4DTaskConcrete*) + 987
11 com.4d.4d 0x00340897 V4DTaskManager::_Task4DProc(xbox::VTask*) + 147
12 com.4d.kernel 0x037314aa xbox::VTask::_Run() + 90
13 com.4d.kernel 0x03736372 xbox::XMacTask_fiber::_ThreadProc(void*) + 82
14 com.4d.kernel 0x0377213b xbox::VMacFiber_thread::_ThreadProc(void*) + 43
15 com.apple.CoreServices.CarbonCore 0x9490a064 CooperativeThread + 290
16 libsystem_pthread.dylib 0xa7ccc5f8 _pthread_body + 137
17 libsystem_pthread.dylib 0xa7ccf7f7 _pthread_start + 78
18 libsystem_pthread.dylib 0xa7ccb7ce thread_start + 34

When you get a runtime error, what was reported? May be there is a clue i there.

Since you are able to open and connect to the same application in Client Server mode, you can try comment out your On Start method through Client connection. Then give it another try in the Standalone. We need to determine if the crash occurs in the On Startup or before.

I can trace On startup on the developer as well. The debug window opens on Trace command, then i can run step by step the on startup method. If i run it to the end, the start menu and button form shows up.

It seems that any menu or button that starts a new process will fail.

Have access to some menus that shows forms within the startup process, they are ok.

But when i tries to access any menu/ button that starts a new process, the crash comes instantly.

Hilsen

That sounds like a very unusual situation. Do you see the same behaviour with any structure file on that same Mac, for example, with a newly created 4DB?

No, not tested with a new db.
Have run maintenance on the server, repair and compact of structure, copied structure to two other macs, tested with developer on this macs - same result - crash.
But the same application on the server is up and running, no problem to access all the menues from client, new process shows listbox etc… No problem with the developer layer, 1 orphan method after repair/compact but everything else is ok.

Strange?