Certification matrix

When will there be a certification matrix for 17.1 please? I can see a technical requirements document that states MacOS 10.12 - is that the oldest compatible OS, oldest certified OS? It will be a big help in my release planning if I know in advance what versions are compatible / certified for use with 17.1

Thanks,
David

Please see: https://us.4d.com/product-download/4D-v17

macOS Sierra 10.12 - macOS Mojave 10.14
(latest release of major version is required, such as 10.12.6)

In case this is unclear, it means that 10.12, 10.13 and 10.14 are certified, but for each version the latest sub version. 10.12.6 for 10.12, 10.14.3 for 10.14. We do not test older sub-versions as 10.12.0.

https://download.4d.com/Documents/Products_Documentation/LastVersions/Line_17/VIntl/PDF_Format/4D_v17_1_SystemRequirements_EN.pdfHere> :wink:

Thanks Manuel, Thomas,

I’d seen that document and wondered if it was taking the place of the old matrix with certified / compatible / not compatible entries.

I’ll start advising the sites with 10.11.x that they need to upgrade.

Beware this type of iMac is no more compatible

[]28711937;“Too old…”[/]

Edit: For this computer this is not the OS but EVEN the CPU is NOT compatible with v17 !

This is the second time we have the problem for a client… :frowning:

Thanks! Is there any way to retrieve that info (15G31) via a command or method?

That is almost 12 years old computer, I am using it just to listen podcasts or music while I work in the office, your client should upgrade.

: David STEVENSON

Thanks! Is there any way to retrieve that info (15G31) via a command
or method?

Call sw_vers command using https://doc.4d.com/4Dv16/4D/16.4/LAUNCH-EXTERNAL-PROCESS.301-3979385.en.htmlLAUNCH EXTERNAL PROCESS> and parse result.

4D have simplify the problem, now for 4D v17.1 the minimum os is now 10.12.6; but during a long time, the minimum os for the v17 was 10.11.x but that is not the only problem, the CPU need to be more recent that 2008 to be compatible.

So now if you respect the new certification there are many iMac that wil be no more compatible.

[]28712223;“All those computers are obsolete now…”[/]

Sorry if that type of computer still working… :roll:
If it was PC you only have 3 years to use it :twisted: :mrgreen:

$osVersion:=Get system info.osVersion

returns something like

macOS 10.14.3 (18D42)

https://doc.4d.com/4Dv17/4D/17.1/Get-system-info.301-4179393.en.html

: Manuel PIQUET

4D have simplify the problem, now for 4D v17.1 the minimum os is now
10.12.6; but during a long time, the minimum os for the v17 was 10.11.x

If you go back in history, you will notice a pattern.
4D supports the latest 3 macOS versions.

Usually (but there is no guarantee), it is possible to build a macOS application running on 3 different Apple API sets. You can see this like a range, a window. It could be 10.10, 10.11 and 10.12. Or 10.12, 10.13 and 10.14.

Whenever we want to add support for a newer OS, an older one falls out of that range.

When 4D supported 10.13, 10.10 went away.
Now, with supporting 10.14, 10.11 went away.

Based on the behavior of the last years, we expect that supporting 10.15 will mean to stop supporting 10.12.

Note that Apple itself only supports the latest 3 versions. 10.12 is currently the oldest version getting security updates. If you are still using 10.11, the latest security updates provided was 6 months ago, meaning using this system is a high risk. At least customers located in Europe using computers to handle personal data (such as phone numbers or email addresses) will see conflicts with GDPR, so being forced to update to 10.12 (which could force to replace the hardware).

I am ok with that; this is just a constatation(warning), not an attack… :expressionless: