Changer langue dans méthode

Bonjour Arnaud. 1 installation de 4D sur 2 ordinateurs. Les méthodes de la même base s’ouvrent systématiquement en français sur l’un des ordis et en anglais sur l’autre.
Ce que vous aviez préconisé en son temps :
“ouvrir les préférences de la base / onglet base de données / comparaison de texte / langue du fichier de données : si c’est japonais, tu changes, tu recompiles le composant et ça roule”
Cela ne fonctionne pas.
Je pense qu’il faut agir en amont, avant l’ouverture de la base ?
Merci pour la solution.

Bonjour Jérôme,
voir dans les préférences de 4D :
menu 4D/préférences/Méthodes/Options/Langage de programmation
Très probablement tu as un ordi où ce doit être réglé sur fr et l’autre sur en.

Le message que tu mentionnes est un cas nettement plus tordu, quand un composant est made in japan. Ça n’a rien à voir avec le choix du language de programmation.

PS :

tu n’as pas besoin de m’adresser un fil que tu démarres : c’est très flatteur mais je suis loin d’avoir réponse à tout, je suis juste plus bavard que la moyenne :wink: . À la limite, ce faisant, tu peux même te priver de réponses de contributeurs qui vont se dire qu’il est inutile de répondre puisque d’emblée la question restreint le champ des “répondeurs” possibles.

1 Like

Arnaud Forums :sweat_smile:

Bien compris. Mon problème est résolu. Merci.

Arnaud 's Forum pour être plus conforme avec la langue de Sakespeare :wink:
Mais je valide

Ça dépend si Arnaud se considère maintenant comme une marque déposée :grin:

1 Like