CODIGO DE BARRA SVG typo 128C

Buenas a todos

Componente excelente con el que creo el código de barras en SVG
http://kb.4d.com/assetid=50574

Al imprimir con este componente un código de Barras TYPO Code128C, lo genera perfectamente, pero al momento de leerlo con un escáner el código retornado siempre tiene un cero inicial

Alguien sabe cómo arreglarlo o si es normal que el lector muestre un cero antes código original

Mi código original 1203201901179182150500120010220000180561018617219

La lectura 01203201901179182150500120010220000180561018617219

Muchas gracias por cualquier ayuda para aniquilar el primer cero jajaja

Saludos a todos

Product :4D - 4D Server
4D : v13.2
OS : Windows

El EAN128 es una bestia parda dificil de domar. Hace mucho que no lo uso y no recuerdo bien las condiciones de codificación, pero me temo que tu “código original” necesita ese cero, creo que el lector entiende que falta y por eso lo devuelve por defecto, pero sólo lo creo.

Te adjunto unos documentos por si te pueden ayudar.

Saludos.

https://forums.4d.com/4DBB_Main/x_User/4915/files/28970416.pdf
https://forums.4d.com/4DBB_Main/x_User/4915/files/28970425.pdf
https://forums.4d.com/4DBB_Main/x_User/4915/files/28970430.pdf

Te agradezco muchos los manuales los voy a revisar, El componente no es de mi autoría, es libre para programadores 4d, lo puedes bajar si es de tu interés

¿Utilizas la versión con el bug corregido?

The Tech Note component has an error creating for Code128C the correct checksum in some cases (big thanks to Rudy Mortier for finding, reporting AND fixing). Update published on

https://github.com/ThomasMaul/Barcode_SVG (as v13 structure)