First run of 4D 18 on macOS: solved

Today I faced this problem to upgrade 4D Server 18R2 public version on HighSierra.

4D Server 18R2 beta was already installed and worked without problem. After downloading the public 18R2, Apple says me ”you should place your application in the trash can, it is corrupted”. But in the same time, regular 4D launches quietly.


What’s wrong?


4D server has no plugin installed. When installing 4D internet commands inside the dedicated folder of 4D server you modify some checksums and 4D server appears to be broken.

The good pratice for macOS:

  1. do a first run of server
  2. if OK, quit
  3. intall all your stuff
  4. relaunch

That’s all! :pray:

I do not fully agree.

Good - or best - practice on macOS is never to modify an application.
So do not install plugins into a product app package.
install them in your structure plugins folder, not in the application.

True, that was different in the past but Apple changed the rules, so we do not recommend to use the plugin folder inside the application package any longer to install plugins, install them in the structure.

So, is it not an opportunity for 4D to remove those folders?

That break compatibility. Somebody might want to use them, for whatever reasons.
On Windows there is no strict law against it (while not recommended as well).

We try to avoid breaking compatibility if possible.

Out of curiosity, what is the merit of installing a plugin inside 4D Server?

The plugin will be available on the server side only, missing on the client. Is that the intension, to not transmit plugins that are large and unneeded on the client? Since plugins are cached on the client side, I would assume that it would always be better to install plugin adjacent to the structure (or project).

I never thought about this point and why, since 4D server requires the component?

Until now, I installed 4D plugins (in fact IC) server side and plugins follow 4D versions.