Formus "Select a Version" out of date

in this forum: the “Select a version” drop-down list is slightly out of date:
2004.8 through 13.1???

Could you also add 13.2?
(and maybe 17r6 or 18 while you’re at it?)