Integrated web area blocks cookies on Windows

Product :4D - 4D Server
4D : v15r5
OS : Windows 10

I’m working on a project whereby I need a 4D app to authorize with Office 365.
I use a form with the integrated web area to open a URL with the login page for the authorization.

On Mac this works well. No problems at all.
On Windows I get this message from Microsoft:
“Your browser is currently set to block cookies. You need to allow cookies to use this service.”

When I disable the integrated web area, it also works well on Windows. But then I lose the ability to call 4D methods, which I also use.

Does anyone have a solution for this?

: Rob LAVEAUX

Does anyone have a solution for this?

Instead of calling 4D-methods directly from a html-page – leaving concerns besides–, I’ve settled on REST-like URLs and filter those URLs.
Works like a charm.

using integrated WebKit there is always a wall to run against when connecting to the real world, outside of my 4D-environment. Connecting to outside-world always happens earlier or later in the project-phase. So not being excited about Blink at all.