Liste vers blob et blob vers liste

Bonjour,

C’est deux commandes fonctionnent super bien. J’ai cependant un problème avec la récupération d’une liste qui contient des images. Il semble que ces dernières ne soient pas récupérées dans le cadre de Blob vers liste.
Quelqu’un confirme ?

Patrick

Jamais utilisé. Tu as une mini base de test ?

yes the icons are lost if you pack a list as blob.

you need to preserve and reattach them seperately.

it is what I do in this example: https://github.com/miyako/4d-component-classic-query-editor

Non, mais il semble que cela soit normal d’après la réponse de Keisuke que je remercie
Je vais donc regarder comment faire cela.

Cette particularité pourrait être ajoutée à la doc par contre.

Patrick

Thanks a lot Sir Keisuke

I just had a look on the component and that means I have to reattach the initial icon to each item.
This particular point should be notified in the documentation at least in ‘BLOB to List’ command.

Patrick

: Patrick EMANUEL

Non, mais il semble que cela soit normal d’après la réponse de
Keisuke que je remercie
Je vais donc regarder comment faire cela.

Cette particularité pourrait être ajoutée à la doc par contre.

J’imagine que tu sais comment contacter la doc.

Dans ton cas, utilises donc https://doc.4d.com/4Dv18/4D/18/FIXER-PARAMETRE-ELEMENT.301-4505734.fr.htmlFIXER PARAMETRE ELEMENT> au moment de blober

: Bertrand SOUBEYRAND
J'imagine que tu sais comment contacter la doc./quote]

Oui oui, t’inquiètes :wink:

: Bertrand SOUBEYRAND
Dans ton cas, utilises donc FIXER PARAMETRE ELEMENT> au moment de blober
Dans mon cas, je pense que j'irai tout aussi vite à recalculer la LH. Je voulais m'éviter cela mais bon, d'autant plus que je cumul les icônes à certains endroits ;-)