Message d'erreur sur mise à jour 4D client

Bonjour,

Chez un client nous rencontrons un soucis :

  • poste serveur Pc 64 bits sous 4D v17 64bits
  • poste client Mac Os 10.10

Lorsque le le poste client essaye de se mettre à jour par rapport au serveur on obtient le message d’erreur []30670708;""[/]

Cette même manipulation (dans des cadres similaires) a déjà eu lieu dans notre parc de clientèle sans soucis particulier; c’est la première fois que nous rencontrons cela…

Merci bien à qui pourra nous aider !

Il y a eu un bug sur une archive du moteur de zone web mais cela concernait https://forums.4d.com/Post/FR/30624051/0/0/les R releases> :?:

Du coup, peut-être que cela touche également les versions non R :doubt:

C’est quoi le n° de build que vous utilisez exactement ?

Après, le minimum requis pour utiliser les dernières versions v17.2 c’est macOS 10.12.6 minimum…

Bonjour Manuel,

Je suis sur la build 17.230190
Je compile sous Mac Os 10.13 mais ça je ne sais pas si ça peut influencer…

êtes-vous partenaire 4D ? avez-vous accès au lien de mon précédent post ?

Il s’agit visiblement du même probleme, mais il ne semble pas être corrigé dans le R release.
Il est de plus surprenant que vous le rencontrez dans les releases courantes.
C’est certainement dû au fait que vos clients sont en 64 bit.
Je déploie toujours avec des clients en 32 bit (avec des serveurs en 64 bit) donc je n’ai pas rencontré ce problème de mon coté.

Certes mais sur PC le serveur 32 bits n’existe plus :expressionless:

Pour le lien oui, et c’est d’ailleurs le même cas de figure où le client d’origine est en v12 ou v13 (je n’ai pas l’information exacte)

Le problème vient bien du CLIENT pas du serveur (directement); c’est l’archive du client sur le serveur qui pose problème ou le client déjà installé qui se met à jour.

Le problème semble limité aux clients 64 bit ? je ne l’ai pas rencontré de mon coté. J’utilise des serveur 64 bit, mais uniquement des clients en 32 bit.

J’utilise des serveur 64 bit, mais uniquement des clients en 32 bit.
Pourquoi ?

ouais, c’est bon, ça va, je sors…

: Manuel PIQUET

Le problème vient bien du CLIENT pas du serveur (directement); c’est
l’archive du client sur le serveur qui pose problème ou le client
déjà installé qui se met à jour.

Le problème semble limité aux clients 64 bit ? je ne l’ai pas
rencontré de mon coté. J’utilise des serveur 64 bit, mais uniquement
des clients en 32 bit.
Comment faites-vous pour avoir uniquement des clients 32bits avec un serveur 64bits ?

Rien de spécial, nous sommes éditeur donc on déploie des versions OEM. Au moment de la compilation le code se compile pour les 2 (option dans les préférences 32 et 64) mais pour les clients au moment de la build, je n’utilise que le 4D Volume Desktop 32-bit et pour le serveur le 4D Server (64 bit).

Après, j’ai encore une autre particularité, j’utilise toujours l’ancienne couche réseau (legacy).
Mais c’est plus par choix (j’avais rencontré trop de problèmes liés à la nouvelle couche réseau).

Si j’avais une solution je passerais tout en 64 bit mais nous utilisons les plugins 4D Write et surtout 4D View donc pas le choix pour l’instant… :frowning:

: Manuel PIQUET

Après, j’ai encore une autre particularité, j’utilise toujours
l’ancienne couche réseau (legacy).
Mais c’est plus par choix (j’avais rencontré trop de problèmes liés à
la nouvelle couche réseau).
Pour info, on a déployé la v17 avec la nouvelle couche depuis mars, rien à signaler - c’est même nettement mieux, je dirais.

Dans ton cas, gérez-vous des licences (les votres pas seulement celle de 4D) de votre produit ? Qu’en est-il de la gestion des clients endormis ? Est-ce un applicatif ou seulement un serveur web ?

: Manuel PIQUET

Dans ton cas, gérez-vous des licences (les votres pas seulement celle
de 4D) de votre produit ? Qu’en est-il de la gestion des clients
endormis ? Est-ce un applicatif ou seulement un serveur web ?
Rafale de questions…
1/ pas de gestion de licence dédiée, que celle de 4D
2/ rien vu de spécial sur les clients endormis
3/ C/S + serveur web + un “client serveur web”

Ça va dériver du sujet, mais je m’étais demandé, pourquoi fais-tu le 1/, d’ailleurs ?

Ben, on vend une solution, on est éditeur chez 4D (donc c’est à nous de gérer les licences), mais on n’est pas open bar chez nos clients (ils achètent une certaine quantité de licence de notre produit qui n’est PAS limité par les licences 4D).

De plus, pour complexifier un peu les choses, on gère différents types de licences (licence light et licence pleine) pour notre produit.

Sauf que cette gestion de licence est liée fortement à la gestion des utilisateurs (licence 4D sur le serveur 4D). Donc, si on n’arrive pas à maintenir la liaison entre les 2, ben plus rien ne fonctionne et comme les clients endormis se libéraient jamais ! patatras… :twisted:

Bonjour

Avez vous déclaré le bug :?:

Pour ma part toujours présent en 17R5