Miyako Plug-in 4D COMMON STRING ALGORTHM erreur priviliege

Bonjour,

je fais suite a unhttp://forums.4d.com/Post/FR/26897419/1/26897420#26897420 precedent sujet>, ‘erreur de licence ou de privilege’ du plug in COMMON STRING ALGORITHM.

Cela marchait très bien en v15 mais ne fonctionne plus en v16 v17 alors que j’ai toutes les licences.

QQ1 aurait une suggestion svp?

Merci d’avance

J’ai essayé une regeneration avec http://www.4d.com/fr/support/resources/features/4dpluginsdk.html

et https://github.com/miyako/4d-plugin-wizard , je n’arrive pas a créer un plugin qui fonctionne …

Il est toujours indiqué comme ‘désactivé’ dans la liste des plugin de la base ouverte.

J’ai loupé qq chose?

Je n’ai pas résolu le problemes… j’ai refait une méthode avec la distance de Levensthein en langage 4D et étendue a des comparaisons de mots dans l’ordre ou pas dans des phrases. http://forums.4d.com/Post/FR/26923165/1/26923166Code source ici> :wink:

Pour cette question d’erreur de privilège, je n’ai toujours pas compris …:roll:

the licenses error is the default error message when a library or executable can not be loaded.

it may have nothing to do with licenses. (my plugins never check licenses)

in this case it is returned simply because you are using a 32-bit plugin with a 64-bit 4D.

(remember, the standard installation for Mac is 32-bit for v15, 64-bit for v16 and v17)

Thank Keisuke ^^