On passe de la V17.1 à la V17 r4?

Bonjour à tous,

J’ai un petit souci de compréhension sur le versionning 4D
En effet, j’étais en V17 r2, je suis passé en V17.1 et là, 4D me propose une 17r4 (donc une version plus faible que la V17.1)

Je pensais que les version Release permettait de nous mettre à jour (ceux qui ont un suivi logiciel) avant les version dispo “public”
Donc pour moi, la 17r4 devrait être la 17.1 r2

En gros, toutes les modifs que j’ai faites avec le 17.1 sont elles comprises dans la 17r4 ? Car je voudrais bien utilisez la r4 pour l’export .docx, le mode préemptif (pour enfin pouvoir passer certains clients en TSE) et l’envoi des mails.
Mais si je perds les fonctionnalités de la V17.1, cela me gène.

Merci de vos explications et conseils

F. BOUSSON

Bonjour

La 17.1 est une mise à jour mineure de la 17.0

La 17R4 contient des nouveautés depuis la R1, qui ne seront jamais en 17.X, mais seulement en 18

Donc la 17R4 est plus avancée que la 17.1, exemple l’export docx ne sera pas intégré en 17.X

[]29434947;“Your comment here…”[/]

Attention tout de même, la R4 est sortie mais ne bénéficiera plus de correctifs.
Si un bug est trouvé, il sera (éventuellement) corrigé dans la future R5 (dans 3 mois).

La 17.1 c’est différent, si un bug est trouvé, il pourra être corrigé dans une Nighty build.

La différence entre les versions R release et les releases 17.x ne se situe pas seulement au niveau des fonctionnalités, mais il y a également une différence au niveau de l’intégration des corrections des bugs.

Attention également, la future R5 ne sera plus compatible 32 bit.

OK, je comprends mieux

Donc, aucun intérêt de passer les V17.x puisque que les V17r sont plus à jour.
Je redescends donc mes clients et mon dev en 17r4

Merci pour l’explication.

Attention aussi la 17.1 demande au minimum OS X 10.11 alors que la 17R4 c’est macOS 10.12 :wink:

Hélas ce n’est plus vrai !

https://download.4d.com/Documents/Products_Documentation/LastVersions/Line_17/Vf/PDF_Format/4D_v17_1_SystemRequirements_FR.pdf4D a changé cela >le minimum requis pour la v17.1 est maintenant macOS 10.12.6 également.

C’est d’ailleurs une première (il me semble) qu’un changement aussi radical de minimum d’OS se produise durant une même release .x .

ah oui autant pour moi :wink:

On va dire que c’est compatible 10.11, mais pas certifié :!:

Attention https://forums.4d.com/Post/FR/28710388/1/28712233#28712233certains postes> bien qu’étant en 10.11.6 possèdent des CPUs qui ne sont PLUS compatibles avec la v17 !