Plugin pas zipper 32

J’ai un souci avec https://github.com/miyako/4d-plugin-zip4d plugin zip> sous macOS sierra et 4dv17r4. Il marche parfaitement en 64 bits, mais ne veut plus de moi en 32 bits :

Code :
Erreur lors de l’exécution de la méthode “xxxx” à la ligne 15
Erreur de licence ou de privilège. (Zip (3.7))
Error code: -9949 (4DRT)
Erreur de licence ou de privilège. (Zip (3.7))
component: ‘4DRT’
task -7, name: ‘P_1’
Impossible d’exécuter la méthode du plug-in.

Ça se soigne ?

v3.7 does not contain 32-bit binary,

because I used a newer version of Xcode to notarize it. (X code 9 was that last that supported 32-bit)

do you need a 32/64 version for Catalina? (e.g. mixed environment)

I suppose it is possible, by using 2 version of X code and manually combining the result)

it’s not something I would consider for every plugin, moving forward…

Hi Miyako,
I made this:

if(64)
use 4d zip plugin
else
use 7z component
end if

As I don’t plan to keep 32b version centuries, that’s ok for me.

Thanks a lot for answering - and for your useful tools :wink: