Probleme identifiant sur serveur smtp gandi

Bonjour,

j’arrive à envoyer des mails avec le serveur smtp gandi via quicksend avec authentification

$Erreur:=SMTP_QuickSend ($NomServeur;$MsgDe;$MsgÀ;$Objet;$Message;0;587;[CONSTANTE]MAIL LIBELLE;[CONSTANTE]MAIL MOT DE PASSE)

je n’arrive pas à faire de même ( car besoin d’envoyer pièce jointe ) avec SMTP_Send comment indiquer le port 587 puisque cela marche avec le 587 ?

A noter que sur smtp bbox sans authentification mon scripte ci-dessous marche

: (Non(Wr_Verif (“SMTP_New”;SMTP_New ($SMTP_ID))))
: (Non(Wr_Verif (“SMTP_Host”;SMTP_Host ($SMTP_ID;[CONSTANTE]MAIL NOM SERVEUR;0))))
//: (Non(Wr_Verif (“SMTP_Host”;SMTP_Host ($SMTP_ID;“smtp.bbox.fr”;0))))
: (Non(Wr_Verif (“SMTP_From”;SMTP_From ($SMTP_ID;[CONSTANTE]MAIL FROM;0))))
: (Non(Wr_Verif (“SMTP_To”;SMTP_To ($SMTP_ID;$MsgÀ;0))))
: (Non(Wr_Verif (“SMTP_Subject”;SMTP_Subject ($SMTP_ID;$Objet;0))))
: (Non(Wr_Verif (“SMTP_Comments”;SMTP_Comments ($SMTP_ID;“Envoyé via 4D”))))
: (Non(Wr_Verif (“SMTP_Body”;SMTP_Body ($SMTP_ID;“ceci est le corps du mail”;0))))
: (Non(Wr_Verif (“SMTP_Attachment”;SMTP_Attachment ($SMTP_ID;$chemin;2;0))))
: (Non(Wr_Verif (“SMTP_authentification”;SMTP_Auth ($SMTP_ID;$mail serveur;$mail mdp))))

: (Non(Wr_Verif (“SMTP_Send”;SMTP_Send ($SMTP_ID;0))))

merci de votre aide

Bonjour

IT_SetPort (2;587) // cf internet commands

Ça marche

merci

De rien.Ce n’est pas évident à trouver dans la doc quand on a les yeux rivés sur le chapitre “SMTP” :slight_smile:

j’ai un petit problème en faisant du mailing avec une pièce jointe créée avec 4d write les accents et autres caractères français sont incohérents sur cette pièce jointe. J’utilise l’imprimante PDF virtuelle de window 10.

merci d’avance