Unable to edit database

Hey all,

Pretty new here. Also very new to 4d from a development standpoint. I followed some of the tutorials on the 4d website and was able to follow their instructions etc.

Now however in the real world with a real 4d database I can’t seem to edit it. I enter in designer mode with a dev license and all the tools are grayed out. I can’t really do anything. What am I doing wrong? There has to be some way to edit it that I am not seeing.

Also using 4d v17 on mac.

Hi Evan,
Welcome to 4D. (I mean that sincerely, not ironically, btw.)

Without know exactly what :
Evan STANFIELD

a real 4d database is let me describe the most likely scenarios that fit what you describe.

  1. The database you are attempting to open is compiled.
    Is the file you opened named “mydatabase.4DC”? If so it’s compiled and you can’t edit it and thus the tools are all greyed out.

  2. The database may have a default user defined which doesn’t require the password to startup.
    To get to the Design mode on a Mac hold down the Command Alt key and right click on a form. You should see a popup menu with a Go to design option.

If the file is named “mydatabse.4DB” were you prompted for a password?
The database may have a designer password. Without that password you won’t be able to edit it.

  1. The actual file may be locked for some reason.

Where did you get the database you are attempting to open?

Hope this helps.

: Evan STANFIELD

There has to be some way to edit [my database] that I am not seeing.

By any chance did you choose “Run -> Restart Compiled”?

If so, choose “Run -> Restart Interpretive” to once again edit in the Design Environment.

Got it! TY!

I was opening the 4.dc database.

We have a relatively simple system (i think) no plugins etc. I have pretty minimal experience with code with the exception of some rudimentary python knowledge, i.e. Hello World. We are a very small family business and we can’t find stable 4d experts. We are just too small to keep anybody working on our database.

SO that being said, I’m trying to teach myself in hope that I can make some of the small changes.

I was opening the wrong file! Ty!