V17.2 (Not optimized for MacOS?)

macOS 10.14.6 displays this warning (#1):

But System Info reports (#2) 64-bit state:

Why is “https://support.apple.com/en-us/HT208436Not optimized>” being reported?

Apple’s message is not only about the main app itself, also about all included libraries or helper files.

I don’t know if you have plugins being 32 bit, but I assume the message is about PHP.
You can test using terminal and enter:
file /Applications/4D\ v17.2/4D.app/Contents/Resources/php/Mac/php-fcgi-4d

which will give:
Mach-O executable i386

4D v17.x is shipped with PHP version 5.4.11 in 32 bit format, to allow usage in both 32 and 64 bit builds.

Starting with 4D v17 R5 PHP is upgraded to 7.3.1 in 64 bit only.
file /Applications/4D\ v17\ R6/4D.app/Contents/Resources/php/Mac/php-fcgi-4d
Mach-O 64-bit executable x86_64

See: https://blog.4d.com/64-bit-support-brings-new-opportunities/
about PHP upgrade and other library changes.

While PHP 7 brings new features, it also has several compatibility issues requiring to modify existing PHP code. As result we cannot simply introduce such a major compatibility issue in a .x release. See:
https://www.php.net/manual/en/migration70.php

If you do not use PHP, need full 64 bit and cannot migrate to R5, you might want to remove the whole PHP folder for deployment.