Virgules non visible lors de l'affichage des numériques?

Bonjour,

j’ai passé mon application en V18 mode projet et je me retrouve face à un problème assez étonnant, je ne vois plus aucune virgule sur mes champs numériques. A la place de ça, je me retrouve avec un espace.

Quand j’essaye de jouer avec les formats j’ai différentes réactions mais jamais celle souhaitée.

Quelqu’un pourrait m’expliquer simplement le nouveau fonctionnement des format numérique ?

Ca me rappel le un problème que j’avais eu lors d’un passage d’une application 4D de Mac à windows.

Le délimiteur décimal était bien là mais invisible car la taille d’affichage était pas suffisamment haute ! Et donc impossible d’afficher la virgule.

Essayez de changer la taille de la police ou la taille d’affichage du champs.

Bonjour,

Ce n’est pas lié à la v18, mais avez “converti” votre base ou “créé” une nouvelle base ?

Conversion j’imagine ?

Si c’est le cas il y a une option de compatibilité qui définit si le . et la virgule doivent être utilisé ou pas comme séparateur de milliers et décimaux. Disons plutot comme “place holder” pour les séparateurs de milliers et décimal défini dans le système.

Cette option n’est normalement PAS activée par défaut dans les bases converties.

Selon que cette option est activée ou non, le comportement est différent.
Dans un cas les virgules et point sont consédérés comme séparateurs de milliers et décimaux et à l’affichage, les séparateurs définis dans le système seront utilisés à leur place. C’est la façon moderne (et souple) de procéder.
ex: ###,##0.00 affichera123 456,78 en France

Dans le cas contraire, rien ne doit changer en principe.


Dans une nouvelle base, cette option est activée tout le temps (et ne peut pas être désactivée).
Vous devez donc obligatoirement utiliser le poit et la virgule comme séparateurs dans les formatages.
ex : “###,###,##0.00” -> 123 456,78 au runtime (toujours avec formatage français)

Roland Lannuzel

Je vois, j’ai modifié mes formats et effectivement ça rend le bon résultat.

Merci pour l’information

LA Bonne pratique :

définissez votre format une fois pour toutes ! :slight_smile:

[]33513595;“Your comment here…”[/]

Si vous faites ça, vous gagnerez beaucoup de temps !

Cordialement

Roland Lannuzel

Si j’avais qu’un seul format dans l’application, ce serait simple :lol: