Why does 4D does not respect my regular 4D filtering option all disabled for

Hi,

We have a database where the 4D filtering option is set to “disabled for all”
However, in some installations we still get Error 48 in 4D Write pro documents where we use expressions.

We have Enable user settings in external file checked
Can there be a problem with our installation?
Why do we still get Error 48 although we allow all commands and methods?

Where is this setting stored?

Thanks in advance,
Piotr

“Disabled for all” in “Security page” is a compatibility option, designed to help customers migrating from 4D v6.x to v2003. To make it more easy to migrate with existing documents and update the code step by step.

It is not possible to use new tools or commands with this old, dangerous, compatibility setting.
4D Write Pro and 4D View Pro are created to be secure, without an option to disable this.

Reminder: if this option is disabled, a customer can use commands such as TRUNCATE TABLE.
This is not a real dangerous command, as the action follows directly the usage, so easy to find. And not dangerous, as long the customer has a backup.

Really funny are commands such as START TRANSACTION used inside a quick report (or 4D Write document).
All works fine, and then the client quits when leaving and starts again next day (or after weekend), he will realize that all the work from last day is gone, while the work from all other employees is still here. So no way to use the backup.
And they will complain that your application (or 4D) “lost” all his data.

We recommended URGENTLY to use this option 20 years ago.

And now, 20 years later, it is mandatory for new created code, such as for 4D Write Pro.
You need to have a list to whitelist methods.
If you love risky games, set “@” as methods. You was warned, but then it is your decision.

Hi Thomas,

Thanks again for your quick response, and I understand what you are saying.

However, how is it possible that the same engined application gives on some installations Error 48 but on others no error at all
We have tested our app in a development and test environment and all works fine. But now, after installing the same version for production, suddenly, on some machines we get this error 48
Can you explain this?

Gr,
Piotr

Hi,

We found the problem
It seems that when the Preferences folder is missing in the database folder, and 4D is not able to create the Preferences folder, the error appears

Gr,
Piotr